InboxRULES for Outlook



InboxRULES for Outlook

Table of contents

What is InboxRULES

InboxRULES for Outlook is a modular system for processing incoming and outgoing messages. They are processed when they arrive to MS Outlook or they are sent from it. InboxRULES for Outlook is a client side engine which requires MS Outlook to run to process messages.


Getting started with InboxRULES

New to InboxRULES

Read the Introduction section to know more about InboxRULES, its different editions and system requirements.

Follow the Tutorials to familiarize yourself with the processes of creating and generating your documentations.


Regular user of older InboxRULES versions

Run through the Tutorials to familiarize yourself with the new version

return to the top

Introduction

About InboxRULES

System requirements

How to buy InboxRULES

About InboxRULES

InboxRULES for Outlook (InboxRULES CE) is an add-in for MS Outlook for processing incoming and outgoing messages. They are processed when they arrive to MS Outlook or they are sent from it. InboxRULES for Outlook is a client side engine which requires MS Outlook to run to process messages.

InboxRULES can help you to save and print messages, extract data from messages immediately when message arrives to MS Exchange Server mailbox or MS Outlook account.

Modular system of InboxRULES consists from client side engine for MS Outlook (InboxRULES CE), MS Outlook Rules (InboxRULES RW) or server side engine for MS Exchange Server (InboxRULES SE), actions and restrictions.  Apart of standard actions and restrictions provided by us, it's possible to develop custom ones by using program API.

System requirements

InboxRULES requires this system configuration

MS Outlook 2000-2013 (32bit only)

MS Windows 2000 and newer

How to buy InboxRULES

To order InboxRULES launch your web-browser to the ORNIC USA, LLC store page at http://www.ornicusa.com/purchase.

Licensing

Engines are free of charge. You only pay for actions and restrictions which you want to use. Actions and restrictions are licensed per workstation. A license must be purchased for each workstation on which you run InboxRULES.

Delivery

All our products are shipped in electronic form. You will receive a license code which you enter to trial version of our products.

Upgrades

You will receive free upgrades (including all major and minor releases) and priority-driven technical support during one year after purchase. After an year passes you'll be able to renew the software at a reduced price.

Our eCommerce is handled by ShareIt

ShareIt which is one of the oldest and most trusted software stores on the Internet. They process millions of dollars worth of software sales each year. Their system is secure and designed to protect both you as a consumer and us as a vendor from fraud and theft. We trust ShareIt with our business and you can trust them too.

return to the top

Installation

Installing

To install InboxRULES for Outlook, run the program ircexxx.exe, where "xxx" is the InboxRULES version number. Then follow the instructions.

Uninstalling

In the Start menu, open the Programs folder, then open the ORNIC folder and then InboxRULES for Outlook folder and select "Uninstall". You may also uninstall InboxRULES for Outlook in the Control Panel Programs and Features applet.

return to the top

Tutorials

How to start InboxRULES for Outlook Manager

How to enter a license code

How to create a new rule by using Rule Wizard

How to create a new rule or edit an existing rule

How to run rules manually

How to start InboxRULES for Outlook Manager

Outlook 2007 and older

Outlook 2010 and newer

Outlook 2007 and older

To start InboxRULES manager you can either click "InboxRULES CE" button in Outlook toolbar or


press "Start Manager" button in "InboxRULES CE" tab in Tools / Options menu.


Outlook 2010 and newer

To start InboxRULES manager you can either click "Manager" button in Outlook "InboxRULES" ribbon or


you can press "Add-Ins Options" button in File / Options / Add-Ins menu and then


press "Start Manager" button in "InboxRULES CE" tab.

How to enter a license code

1. To enter a license code choose "Enter License" item from Help menu in InboxRULES manager.


2. Enter license code into dialog and the press ‘OK’ button


3. If you purchase 'Bundle' product then you get several license codes on separate lines. In that case please enter each license code from each line individually.

How to create a new rule by using Rule Wizard

Rule Wizard is automatically displayed when you open InboxRULES manager or you can whenever open it from "Rules" menu.

1. You can choose either a rule template or start from a blank rule.


2. Now you should define a condition which describes when this rule is called by InboxRULES.


3. Now you can select action which InboxRULES calls for this rule.


4. Finally you can specify a name for this new rule. You can also select if this rule should be enabled and if it should be created for both incoming and outgoing messages. You can also disable showing this wizard at InboxRULES manager startup.


5. When you press "Finish" button your new rule will be inserted between Rules.

How to create a new rule or edit an existing rule

1. To create a rule expand ‘Rules’ item in left tree pane  and select either ‘When message arrives’ or  ‘After message is sent’ item.


2. Press right button on mouse to show up popup menu and select ‘New Rule…’ item. You created your first blank rule. You have to set conditions and actions for this new rule.


3. To enter condition/restriction press ‘Add’ button funder Restrictions list area.


4. In next dialog select restriction type from Restriction list ('Message subject') and condition (contains value 'order'). More details about restrictions you can find in Restrictions section. Don't forget to press 'OK'.


5. To create action use similar method as described in previous item - press 'Add' button under Actions list area.

6. In next dialog select action type from Action list ('Save message') and specify action options.


7. Don't forget to press 'OK' to close all dialog and then Save all changes.


How to run rules manually

InboxRULES can run actions on all messages in selected folder. You just select what rules should be processed and in which folder they should be run.


1. To start "Run Rules Now" dialog you can either invoke InboxRULES Manager and then click on "Run Rules Now" menu item or you can directly click on "Run Rules Now" button in InboxRULES ribbon (Outlook 2010 and newer) or toolbar (Outlook 2007 and older).

"Run Rules Now" button in Outlook 2010 and newer

"Run Rules Now" button in Outlook 2007 and older


2. First you should enable rules which you want to process. You can select from all rules which are defined in InboxRULES.


3. Now you can choose folder where you want to run the rules. you can either click on "Browse" button on double click on Folder name.


4. Finally you should press "Run Now" button to start the process. Whenever you can interrupt it by pressing "Cancel" button.

return to the top

Actions

Extract Message: action extracts the data from message and stores them either into a file, Outlook folder, or personal address book.

Print Message: action prints message body or message attachments

Save Message: action saves message body or message attachments to selected disk folder

Extract Message

1. Introduction

Extract Message action can automatically extracts the data from incoming or outgoing messages and stores them either into a File, Outlook Folder, or Personal Address Book.

Extract Message saves your time. You need not anymore reenter information that are included in an incoming or outgoing message. Extract Message automates this process.

1.1. What is Extract Message for

Extract Message extracts data information from an incoming/outgoing message fields (such as the sender‘s information, subject, message, delivery time etc.) or their segments.

Only text after keyword or selected range of characters can be extracted from the message field.

Extract Message stores extracted data into the File. You can define file type, append or create mode, horizontal or vertical arrangement, data separator, text qualifier and program to execute after output.

Extract Message stores extracted data into the Outlook Folder (such as Contacts, Tasks, Output, Calendar etc.) - folder standard fields (such as Full name, E-mail address, Mail address, etc.) or user defined fields (defined in form).

In case the selected folder is Contact folder you can specify what to do if contact item in contact folder already exists. It can be added, modified, not added, or removed.

In case the selected folder is Output folder the message is sent to an email address that is extracted from an incoming message or set to invariable value.

Extract Message stores an incoming message sender‘s information into the Personal Address Book.

1.2. Examples of Use

The web-form data sent from your web page to your Outlook inbox are recognized and automatically stored into a file or Outlook folder.

Sender/Recipient info can be extracted from an incoming/ougoing message and stored into delimited file or Contacts folder.

Autoresponding in a special format:

o To sent a notice to a sender that his message has arrived.

o To sent a notice about a fact a message comes to invariable email address.

o To sent an Out of Office notice in a special format.

Forwarding extracted data in a special format to an email address (extracted from an incoming message or set to invariable value).

Extracted data stored into the file can be immediately processed with the other program (i.e. imported to the database file, transfer to the web).

1.3. What's New

1.3.1. In Version 2.1

template wizard:

Set an invariable value to an output folder field instead of mapping it.

The value can contain a text, email address, number, logical value or data_time.

Also it can contain a variable that represents an extracted data.

processing:

An output folder field is set by an invariable value.

The %Variable% string is replaced by extracted data value.

1.3.2. In Version 2.0

InboxRules action:

Integration of CaTrap custom action to InboxRules RW / SE.

1.3.3. In Version 1.3

template wizard:

Options: Format of Date/Time setting.

The other terminating characters for keyword parsing: '=', '-'.

processing:

Trap definition: the option "end-of-file" is added (data from AFTER keyword to end-of-message is extracted)

Recipients extraction: Recipient To, Recipient Cc, Recipient Bcc, Recipients To+Cc+Bcc.

New file export option Composed file name.

File mode: if the Create a new file mode is set and file exists the numbered copy can be created.

File structure: Horizontal structure option First line contains field names.

File structure: Vertical structure option Each line contains a field name.

New data separator: TAB and SPACE.

Create a Task: StartDate, DueDate, Reminder

Create an entry in Calendar

new message fields:

Recipient To.

Recipient Cc.

Recipient Bcc.

Recipients To+Cc+Bcc.

1.3.4. In Version 1.2

template wizard:

Template Wizard simplifies the template creating.

Template Wizard use predefined types of templates.

Keywords for data extracting from web-form message are parsed automatically from a web-form message.

Automatic mapping the folder fields from extracted data.

Insert template function to insert a copy of template from the other Extract Message definitions.

Export of templates to the file.

Import of templates from the file.

User-defined-fields are displayed immediately in folder fields list (you need not enter them).

processing:

If Before keyword is not entered and After keyword is entered the text is extracted to the end of the line.

Implicit setting of Categories, Imporance, Flag-for-Follow-up and Sensitivity with constant value.

One extracted data can be stored into more folder fields.

Append mode: extracted data can be appended to the old field value (in case of modifying the folder entry) and separated with selected separator. 

Option of removing leading and trailing spaces of extracted data (default setting).

Inverted commas in keywords can be used in Keywords.

new message fields:

Importance.

Sent.

Transport headers: useful for deleting contacts in case of UNDELIVERABLE message.

new folder fields:

Address City+State+Zip: new folder pseudo-field for parsing of "Columbia, MO 65202" expression.

Categories.

Importance.

Modified.

1.4. Offer for Beginners

In case you have troubles with template definition we can create your first template for you.

Please send us support@ornicusa.com an e-mail with description what do you want to extract from an incoming message (it's better to insert an example of a message) and where do you want to store the extracted information.

Enter "Extract Message beginner" into Subject.

2. Extract Message Description

Extract Message action extracts data information from an incoming or outgoing message fields (such as the sender’s information, subject, body, delivery time etc.) or their segments and stores it either into a File, Outlook folder, or Personal Address Book.

The way of data extraction and storing is defined in templates you can create or modify in Extract Message main dialog with template wizard. That is desribed below.

There are three basic types of templates providing three different types of data storing:

Storing the Data into the File

Storing the Data into the Folder

Stores sender‘s information into the Personal Address Book

2.1. Extract Message Configuration

In the Extract Message main dialog box (picture 2-1) you can create and modify templates defining data extraction from an incoming or outgoing message.


picture 2-1: Extract Message - main dialog box

The template can be also turned off without removing it by clearing the check box next to the template.

You can use following buttons:

New button to start the template wizard. It helps you to create a new template that defines data extraction from a message and extracted data storing (chapter 2.1.1).

Modify button to modify the selected template (chapter 2.1.2).

Copy button to create a copy of the selected template to the same new output template (chapter 2.1.3).

Insert button to insert a copy of template from the other Extract Message definitions (chapter 2.1.4).

Export/Import button to export all templates to a file or import templates from a file (chapter 2.1.5).

Rename button to change the name of the selected template.

Delete button to remove the selected template.

OK button to exit Extract Message dialog box with saving the changes.

Cancel button to exit Extract Message dialog box without saving the changes.

2.1.1. Create a New Template

Click New button in Extract Message main dialog box (picture 2-1) to start the template wizard. It helps you to create a new template that defines data extraction from a message and extracted data storing.

In Template Type dialog box select the type of template you want to create, click Next button and the template wizard will show you the way.

 You can use following predefined types of templates:

Web-form Data into a File (parsed keywords)
Web-form data sent to inbox are extracted and stored into a file. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords are parsed from a web-form message (chapter 2.1.1.1).

Web-form Data into a File (entered keywords)
Web-form data sent to inbox are extracted and stored into a file. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords must be entered manually (chapter 2.1.1.2).

Web-form Data into a Folder (parsed keywords)
Web-form data sent to inbox are extracted and stored into a folder. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords are parsed from a web-form message (chapter 2.1.1.3).

Web-form Data into a Folder (entered keywords)
Web-form data sent to inbox are extracted and stored into a folder. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords must be entered manually (chapter 2.1.1.4).

Sender into a Contact folder
Sender name, e-mail address and subject are stored into a contact folder (chapter 2.1.1.5).

Sender into a PAB
Sender name and e-mail address are stored into a PAB (chapter 2.1.1.6).

Info into a File
Date of receipt, sender name, sender e-mail address and subject are stored into a file (chapter 2.1.1.7).

Info into a Task Folder
Subject, date of receipt and message are stored into a task folder (chapter 2.1.1.8).

Info into a Calendar  Folder
Subject, subject, date of receipt and message are stored into a calendar folder (chapter 2.1.1.9).

Fields into a File
Selected message fields are stored into a file (chapter 2.1.1.10).

Fields into a Folder
Selected message fields are stored into a folder (chapter 2.1.1.11).

Data into a File (blank template)
Advanced definition of storing the extracted data into a file (chapter 2.1.1.12).

Data into a Folder (blank template)
Advanced definition of storing the extracted data into a folder (chapter 2.1.1.13).

2.1.1.1 Web-form Data into a File (parsed keywords)

The form data sent from your web page to your Outlook inbox can be recognized and automatically stored into a file. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords are parsed from a web-form message.

E.g. you want to store data from the following message into the 'Extract Message.txt' file.

In the Select Web-form Message dialog box click Browse button and select the web-form message.

In the Choose Message dialog box select the folder and the message and click OK button.

Now you are again in the Select Web-form Message dialog box and you can see the subject of the selected message. Click Next button to follow-up.

In the Keywords dialog box you can see found keywords. To remove some keyword(s) select it(them) and click Remove button. Click Next button to follow-up.

In the Output File dialog box click Browse button and select the output file or you can click Composed file name to compose the name of the file (Extended Output file dialog box).

In the Open File dialog box select the existing file or enter the new file and click Open button.

Now you are again in the Output File dialog box and you can see the path of the selected file. Click Next button to follow-up. Then you can set Advanced File Options or/and Click Next button to follow-up.

In the Keywords Order dialog box is displayed a list of extracted data that will be stored into a file. Click Move Up or Move Down to change data order in the list box and so to change the data order in output file. Click Finish button to exit the template wizard or click Next to set advanced options (Run a Program).

2.1.1.2 Web-form Data into a File (entered keywords)

The form data sent from your web page to your Outlook inbox can be recognized and automatically stored into a file. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords must be entered manually.

E.g. you want to store data from the following message into the 'Extract Message.txt' file.

In the Keywords dialog box you must enter required keywords. To add a new keyword into the Keywords list box enter it to Add new edit control and click Add button.

You can select the Sorted checkbox to sort the keywords. New keywords will be inserted into the Keywords list and the list will be sorted. In case of clearing the Sorted check box new keywords will be added to the end of the Keywords list.

If all required keywords are entered click Next button.

In the Output File dialog box click Browse button and select the output file or you can click Composed file name to compose the name of the file (Extended Output file dialog box).

In the Open File dialog box select the existing file or enter the new file and click Open button.

Now you are again in the Output File dialog box and you can see the path of the selected file. Click Next button to follow-up. Then you can set Advanced File Options or/and Click Next button to follow-up.

In the Keywords Order dialog box is displayed a list of extracted data that will be stored into a file. Click Move Up or Move Down to change data order in the list box and so to change the data order in output file. Click Finish button to exit the template wizard or click Next to set advanced options (Run a Program).

2.1.1.3 Web-form Data into a Folder (parsed keywords)

The form data sent from your web page to your Outlook inbox can be recognized and automatically stored into an Outlook folder. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords are parsed from a web-form message.

E.g. you want to store data from the following message into the 'Contacts' folder.

In the Select Web-form Message dialog box click Browse button and select the web-form message.

In the Choose Message dialog box select the folder and the message and click OK button.

Now you are again in the Select Web-form Message dialog box and you can see the subject of the selected message. Click Next button to follow-up.

In the Keywords dialog box you can see found keywords. To remove some keyword(s) select it(them) and click Remove button. Click Next button to follow-up.

In the Select Folder dialog box click 'Contacts' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Folder Options click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

2.1.1.4 Web-form Data into a Folder (entered keywords)

The form data sent from your web page to your Outlook inbox can be recognized and automatically stored into an Outlook folder. Data are recognized as a text starting on the right of the keyword (with ':' behind) to the end of the line. Keywords must be entered manually.

E.g. you want to store data from the following message into the 'Contacts' folder.

In the Keywords dialog box you must enter required keywords. To add a new keyword into the Keywords list box enter it to Add new edit control and click Add button.

You can select the Sorted checkbox to sort the keywords. New keywords will be inserted into the Keywords list and the list will be sorted. In case of clearing the Sorted check box new keywords will be added to the end of the Keywords list.

If all required keywords are entered click Next button.

In the Select Folder dialog box click 'Contacts' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Folder Options click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

2.1.1.5 Sender into a Contact Folder

Sender name, e-mail address and subject are stored into a contact folder.

E.g. you want to store data from an incoming message into the 'Contacts' folder.

In the Select Folder dialog box click 'Contacts' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Folder Options click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

2.1.1.6 Sender into a PAB

Sender name and e-mail address are stored into a Personal Address Book.

In PAB dialog box specify what to do if a contact item in the PAB already exists, which means that e-mail address of the new contact is found in any contact of the PAB:

Click the Create radio button to add a new contact.

Click the No action radio button to not add a new contact.

Click the Remove radio button to remove found contact(s).


Click Finish button to exit the template wizard.

2.1.1.7 Info into a File

Date of receipt, sender name, sender e-mail address and subject are stored into a file.

E.g. you want to store data from an incoming message into the 'Extract Message.txt' file.

In the Output File dialog box click Browse button and select the output file or you can click Composed file name to compose the name of the file (Extended Output file dialog box).

In the Open File dialog box select the existing file or enter the new file and click Open button.

Now you are again in the Output File dialog box and you can see the path of the selected file. Click Next button to follow-up. Then you can set Advanced File Options or/and Click Next button to follow-up.

In the Keywords Order dialog box is displayed a list of extracted data that will be stored into a file. Click Move Up or Move Down to change data order in the list box and so to change the data order in output file. Click Finish button to exit the template wizard or click Next to set advanced options (Run a Program).

2.1.1.8 Info into a Task Folder

Subject, date of receipt, message and importance are stored into a task folder.

E.g. you want to store data from an incoming message into the 'Tasks' folder.

In the Select Folder dialog box click 'Tasks' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Folder Options click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

2.1.1.9 Info into a Calendar Folder

Subject, date of receipt, message, sender's e-mail address and importance are stored into a calendar folder.

E.g. you want to store data from an incoming message into the 'Calendar' folder.

In the Select Folder dialog box click 'Calendar' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Calendar Folder Options dialog box click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

In the Advanced Calendar Folder Options dialog box you can set options. Then click Finish button to exit the template wizard.

controls description:

Categories
Entered categories separated with semicolon will be set in new/modified calendar entry.

Importance
Selected Importance level will be set in new/modified calendar entry.

Sensitivity
Selected Sensitivity level will be set in new/modified calendar entry.

Show time as
Selected Show time as option will be set in new/modified calendar entry.

Duration
Selected Duration value will be set in new/modified calendar entry.

Reminder
Selected Reminder value will be set in new/modified calendar entry.

2.1.1.10 Fields into a File

Selected message fields are stored into a file.

E.g. you want to store Sender Name, Sender E-mail Address and Subject from an incoming message into the 'extract.txt' file.

In the Message Fields dialog box you must added required fields. To add a field to the E-mail fields list box select required message field in Add new list box and click Add button.

You can select the Sorted checkbox to sort the fields. New keywords will be inserted into the E-mail fields listbox and the list will be sorted. In case of clearing the Sorted check box new keywords will be added to the end of the E-mail fields list.

If all required fields are entered click Next button.

In the Output File dialog box click Browse button and select the output file or you can click Composed file name to compose the name of the file (Extended Output file dialog box).

In the Open File dialog box select the existing file or enter the new file and click Open button.

Now you are again in the Output File dialog box and you can see the path of the selected file. Click Next button to follow-up. Then you can set Advanced File Options or/and Click Next button to follow-up.

In the Keywords Order dialog box is displayed a list of extracted data that will be stored into a file. Click Move Up or Move Down to change data order in the list box and so to change the data order in output file. Click Finish button to exit the template wizard or click Next to set advanced options (Run a Program).

2.1.1.11 Fields into a Folder

Selected message fields are stored into a folder.

E.g. you want to store Sender Name, Sender E-mail Address and Subject from an incoming message into the 'Contacts' folder.

In the Message Fields dialog box you must added required fields. To add a field to the E-mail fields list box select required message field in Add new list box and click Add button.

You can select the Sorted checkbox to sort the fields. New keywords will be inserted into the E-mail fields listbox and the list will be sorted. In case of clearing the Sorted check box new keywords will be added to the end of the E-mail fields list.

If all required fields are entered click Next button.

In the Select Folder dialog box click 'Contacts' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Folder Options click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

2.1.1.12 Data into a File (blank template)

Advanced definition of storing the extracted data into a file.

E.g. you want to store data from the following message into the 'extract.txt' file.

In the Data dialog box click Define Data Extraction button to Define the Data Extraction.

Now you are again in the Data dialog box and you can see defined data. Click Next button to follow-up.

In the Output File dialog box click Browse button and select the output file or you can click Composed file name to compose the name of the file (Extended Output file dialog box).

In the Open File dialog box select the existing file or enter the new file and click Open button.

Now you are again in the Output File dialog box and you can see the path of the selected file. Click Next button to follow-up. Then you can set Advanced File Options or/and Click Next button to follow-up.

In the Keywords Order dialog box is displayed a list of extracted data that will be stored into a file. Click Move Up or Move Down to change data order in the list box and so to change the data order in output file. Click Finish button to exit the template wizard or click Next to set advanced options (Run a Program).

2.1.1.13 Data into a Folder (blank template)

Advanced definition of storing the extracted data into a folder.

E.g. you want to store data from the following message into the 'Contacts' folder.

In the Data dialog box click Define Data Extraction button to Define the Data Extraction.

Now you are again in the Data dialog box and you can see defined data. Click Next button to follow-up.

In the Select Folder dialog box click 'Contacts' folder and click Next button.

In the Folder Fields Mapping dialog box you can see contact fields mapping from the extracted data. The fields can be automatically premapped according to some data names. Click Finish button to exit the template wizard.

To set Advanced Folder Options click Next button or to adjust the fields (Map the Folder Fields) click Map Folder Fields button.

2.1.2. Modify a Template

Select the template in Templates list box in Extract Message main dialog box (picture 2-1) and click Modify button to start the template wizard. It helps you to modify the selected template that defines data extraction from a message and extracted data storing.

The basic type of the modifying template is selected in Template Type dialog box. Click Next button and the template wizard will show you the way.

If you want to store the same data into the file instead of the folder you can change the basic type.

 

Wizard styles according to basic types:

Data into a File
The wizard style is identical to Data into a File (blank template) type. See chapter 2.1.1.12.

Data into a Folder
The wizard style is identical to Data into a Folder (blank template) type. See chapter 2.1.1.13.

Sender into a PAB
The wizard style is identical to Sender into a PAB type. See (chapter 2.1.1.6).

2.1.3. Advanced Template Definition

2.1.3.1. Define the Data Extraction

In this chapter I explain you how to define data extraction from the message.

E.g. you want to extract data from the following message.

To define 'Title' extraction select the 'Message' field in Definition of Data Extraction dialog box and click Add button. Then enter the 'Title:' keyword into the After edit control. To define the other data proceed similarly.

Click OK button to exit the dialog box.

 

controls description:

Add
Select required message field(s) and click Add to add it(them) to Extracted data description list box. More identical message fields can be added.

Keywords
Select data in Extracted data description list box and click Remove to remove it from the list box.

Keywords
Check this radio button to make active the data extraction based on after (and/or before) keyword(s).

After
Only text starting on the right of the entered keyword (usually a text with ':' behind) is extracted from the message field. Extraction based on keywords is active if the Keywords radio button is checked. If After edit control is empty:

and Before keyword is entered, the text is extracted from the beginning of the message field to the Before keyword.

and also Before edit control is empty, the entire message field is extracted.


Before
Only text before entered keyword (usually a text with ':' behind) is extracted from the message field. Extraction based on keywords is active if the Keywords radio button is checked. If Before edit control is empty:

and After keyword is entered, the text is extracted to the end of the line (End-of-line) or to the end of the message (End-of-text).

and also After edit control is empty, the entire message field is extracted.


Position
Check this radio button to make active the data extraction based on position range of characters. First click Browse button to select the example message for characters range setting. Then click Set position button to select a range of message field characters in Select Range of Characters dialog box. In Select Range of Characters dialog box select the text in edit control, point with mouse to selected text, press right mouse button and choose New option in context menu (see the picture below). Then close the Select Range of Characters dialog box.


2.1.3.2. Map the Folder Fields

In this chapter I explain you how to map folder fields from extracted data.

To map the 'Title' field select the 'Title' in From extracted data list box and 'Title' field in To folder fields list view and click Map to button. To map the other folder fields proceed similarly.

Click OK button to exit the dialog box.

 

controls description:

Map to
Select extracted data item and appropriate destination folder field and click Map to button to set the folder field mapping.

Unmap
Select folder field and click Unmap to clear the folder field mapping.

Clear map
Click Clear map button to clear the mapping of all folder fields.

Properties
Select the mapped folder field and click Properties button to set the way of storing the extracted data into the folder field (Folder Field Properties dialog box). The data can be written (original value is deleted) or can be appended to the original text value.


controls description:

Append
Select a check box and data will be appended to the original text value. Clear the check box and data will be written and original value will be deleted.

Use data separator
Select a separator to separate appended data.

2.1.3.3. Set an Invariable Value to a Folder Field

In this chapter I explain you how to set an invariable value to an output folder field instead of mapping it. The value can contain a text, email address, number, logical value or data_time (see Data Type Conversion). Besides the value can contain a variable that represents an extracted data in format %Variable%.

For example, you want to sent a notice in a special format (see the picture below) to a sender that his message has arrived. Or you want to forward extracted data to an invariable email address.

To set a value of the 'Message' field select the 'Message' field in To folder fields list view and click Properties button.

 

controls description:

Properties
You can set an invariable value of the folder field in edit control (Folder Field Properties dialog box). To insert an extracted data variable to the edit control click right mouse button over the place where you want to put it. Then choice an extracted data item by left mouse button double click. For example, to select 'Subject', the %Subject% string will be inserted to edit control. Then if a message comes to the inbox, the %Subject% string will be replaced by 'Subject' field value.


2.1.3.4. Extended Output File Dialog Box

In this chapter I describe you the File dialog controls that are displayed after Composed file name selection. Thus you can set the variable file name. 

controls description:

File of type
Displays selected output file type. To change the type choose the type from list box.

Prefix
You can enter here the prefix of the file name.

Extracted data
You can select the extracted data value in the file name.

Year, Month, Day, Time
You can set the actual Date and Time in the file name.

Extension
You can select the extension of the file name.

Path
Here is the preview of the file name.

2.1.3.5. Advanced File Options

In this chapter I describe you the Advanced File Options dialog controls.

controls description:

File mode
Select the File mode:

Click Append to append new entry into existing file.

Click Create to create new file every time a message comes. In this case the existing file is rewritten.

Click Create a numbered copy if file exists to not be the existing file rewritten. The numbered copy will be created.


File structure
Select the File structure:

Click Horizontal to add all retrieved data on one line.

Click Vertical to add every retrieved data on new line (for create mode only).

You can use First line contains field names option for the Horizontal structure.

You can use Each line contains a field name option for the Vertical structure.


Data separator
Select data separator to separate retrieved data (for horizontal mode only) and enter separator if 'Another' separator is selected.

Text qualifier
Select text qualifier to enclose each retrieved data.

Remove
Select the check box to remove leading and trailing spaces from the extracted data.

2.1.3.6. Run a Program

In this chapter I explain you how to run a program after storing the extracted data into the file:

Select the check box to make the program execution active.

Click Browse to select program in Open File dialog box.

Enter program command-line arguments. Default argument <file> is replaced with output file path.


2.1.3.7. Advanced Folder Options

In this chapter I describe you the Advanced Folder dialog controls. The entered or selected values are stored in appropriate folder fields implicitly.

controls description:

Categories
Entered categories separated with semicolon will be set in new/modified folder item.

Flag for Follow Up
Select the check box and the Flag-for-Follow-Up will be set in new/modified folder item.

Importance
Selected Importance level will be set in new/modified folder item.

Sensitivity
Selected Sensitivity level will be set in new/modified folder item.

2.1.3.8. Advanced Contact Folder Options

In Advanced Contact Folder dialog box you can specify what to do if a contact item in contact folder already exists, which means that e-mail address of a new contact is found in any contact of selected contact folder:

Click the Create radio button to add a new contact.

Click the Modify radio button to modify found contact(s).

Click the No action radio button to not add a new contact.

Click the Remove radio button to remove found contact(s).


2.1.4. Copy a Template

Select the template in Templates list box in Extract Message main dialog box (picture 2-1) and click Copy button. Then the same new template is created.

2.1.5. Export/Import

Click Export/Import button in Extract Message main dialog box (picture 2-1) to export all templates to a file or import templates from a file.

export:

Click Export radio button to export all templates to the selected file.

Click Browse button to select existing file or enter a new file in Open File dialog box.


import:

o Click Import radio button to import templates from the selected file.

o Click Browse button to select existing file in Open File dialog box.

o Select Remove check box to remove original templates from Template list box before import.

2.1.6. Options Tab

Click Options tab in Extract Message main dialog box (picture 2-1) to set the options.

2.1.7. Notes

2.1.7.1. Pseudo-fields

To allow to extracted data and stored them into not existing folder item fields we defined following pseudo-fields:

Business_Address_Street_2 to set the second line of Business_Address_Street (similarly Home_Address_Street_2 and Other_Address_Street_2)

Business_Address_Street_3 to set the second line of Business_Address_Street (similarly Home_Address_Street_3 and Other_Address_Street_3)

Business_Address_City+State+Zip ("Palm Desert, CA 12261") to set Business_ Address_City ("Palm Desert"), Business_ Address_State ("CA") and Business_ Address_Zip ("12261") from one expression (similarly Home_ Address_ City+State+Zip and Other_ Address_ City+State+Zip)

2.1.7.2. Address Fields in Contact

Address composition
In case you store the data into some of Business_Address_Street, Business_Address_Street_2, Business_ Address_Street_3, Business_Address_City, Business_Address_State, Business_Address_Zip and Business_Address_Country fields, then the Business Address field will be composed automatically. Similarly  Home_Address and Other_Address fields.

Mailing address setting
If you stored the data into more than one type of address fields, they are set like mailing address in following order: Business, Home and Other.

2.1.7.3. Name Fields in Contact

Name composition
In case you store the data into some of Title, First_Name, Middle_Name, Last_Name and Suffix fields, then the Full_Name field will be composed automatically.

Name parsing
In case you store the data into Full_Name field, the Full_Name will be parsed to Title, First_ Name, Middle_ Name, Last_ Name and Suffix fields.

Full Name setting
It is good idea to extracted Sender_Name message field and store it into Full_Name folder field.

2.1.7.4. Data Type Conversion

The following extracted data conversion to folder fields (excluding user-defined-fields - only same types of source and destination value) are supported:

 From data 

 Expected value of From data

 To field

 Text

nn...n, where n={0,1,...9}

 Number

 Text

nn...n, where n={0,1,...9}

 Percent

 Text

nn...n, where n={0,1,...9}

 Currency 

 Text

YES/NO, TRUE/FALSE, ON/OFF, 1/0

 Yes/No

 Date/Time

 

 Text

 Yes/No

 

 Text

 Yes/No

 

 Number

 Number

 

 Text

 Number

1/0

 Yes/No

Print Message

Print Message action prints message body and attachments.

features

print body

print message body in Plain, RTF, HTML format.

customisable message header

adding attachment info to printed body

print to default or selected printer

build-in support for HTML format (doesn't require IE or other internet browser), optional printing of HTML emails by Internet Explorer

print attachments

print message attachments (support normal, embedded and OLE attachments).

print to default or selected printer (only for some attachment types, e.g. graphic files, pdf files, html files)

print all or only specified attachments of email

graphic files are printed through 3rd party software (IrfanView)



Options

Body

Attachments

Other

Body

Action

Enable message body printing: enable printing email body

Message format

Print header: enable printing message header

Print attachments info: print list of attachments to the end of email

Header template: you can define how message header will look like. To get the list of template variables you should right click on the mouse and then select from the menu "InboxRULES Variables" / "Message fields" or "Attachment fields".

Print format:

original format: print body in original message format

plain text: print body in plain text format

rtf text: print body in rtf format

html text: print body in html format

Printer settings

Use default printer: print email to default printer

Printer: print email to selected printer

Copies: defines number of copies to print

Advanced: you can set margins, orientation and collation of printed pages

Attachments

Action

Enable message attachments printing: you should check this option if you want to print email attachments

What to print

You can select what attachment you want to print.

All types of attachments

Specified attachments types only

All types of attachments except specified once


Specify the list of attachment extensions: enter into this field extensions delimited by ";"

Printer settings

Use default printer: print email to default printer

Printer: print email to selected printer

Copies: defines number of copies to print

Advanced: you can set margins, orientation and collation of printed pages

Other

Print settings

Change file associations and print methods settings which is used for printing message body and attachments.

Use default file associations: Specifies whether to use default file associations to print methods for printing attachments

Use default print methods: Specifies whether use default print methods

File associations: Sets file associations to print methods for attachment types

Print methods: Defines print methods

File associations

You shouldn't change anything in this dialog box unless you exactly know what you are doing.

Table columns

Name: Sets name which describes this group of defined file types

Extension: Sets extensions which describe this group of file types

Print method: Specifies print method for defined file types

Hotkeys

You can also use right button of mouse to invoke popup menu on selected line.

Ctrl+Ins: Add new line

Ctrl+E: Edit selected line

Ctrl+Del: Delete selected line

Buttons

OK: Saves changes and closes dialog

Cancel: Discards changes and closes dialog

Set as default: Saves defined file associations as new default settings

Print methods

You shouldn't change anything in this dialog box unless you exactly know what you are doing.

Table columns

Name: Sets name which describes this print method (this name will be offered in print method column of File Associations dialog box

Program: Sets application name which will be used for this print method

Command: Specifies application command line which will be used for this print method

Hotkeys

You can also use right button of mouse to invoke popup menu on selected line.

Ctrl+Ins: Add new line

Ctrl+E: Edit selected line

Ctrl+Del: Delete selected line

Buttons

OK: Saves changes and closes dialog

Cancel: Discards changes and closes dialog

Set as default: Saves defined print methods as new default settings

Save Message

Save Message action can save message body and attachments to files.

features

save body:

   save message body to selected disk folder either in Plain, RTF, HTML, Native format.

   customisable message header

   adding attachment info to saved body

save attachments:

   save message attachments to selected disk folder (support normal, embedded and OLE attachments).

common:

   unique filenames

   run program with saved body or attachment as a parameter

Options

Body

Attachments

Body

Enable saving message body: enable/disable saving body

Output folder: disk folder where action will save body

Output filename: filename of saved body

Header: you can define how message header will look like. To get the list of template variables you should right click on the mouse and then select from the menu "InboxRULES Variables" / "Message fields" or "Attachment fields".

File format:

Original format: save body in original message format

Native format: save body in native message format (.msg)

Plain text: save body in plain text file

RTF: save body in rtf file

HTML: save body in html file


Add header: add message header to saved file

Add attachments info: add list of attachments to saved file

Run program after saving: run program after saving body to the file

Command line:        run this command

Program arguments: use this arguments

Attachments


Enable saving message attachments: enable/disable saving attachments

Output folder: disk folder where action will save attachments

Output filename: filename of saved attachments

Add links to the saved attachments to the message: append a description with file location of saved attachments to the message

Delete attachments: remove attachments from the message

Add shortcuts to the saved attachments to the message: add a shortcut with file location of saved attchments to the message

Run program after saving: run program after saving attachment to the file

Command line:        run this command

Program arguments: use this arguments

Template variables

message variables

[sender] email sender

[sender_smtp] email sender smtp address

[recipients] all email recipients

[recipients_to] "To" email recipients

[recipients_cc] "Cc" email recipients

[recipients_bcc] "Bcc" email recipients (Bcc), valid for sent email only

[recipients_smtp] all email recipients' smtp addresses

[recipients_smtp_to] "To" email recipients' smtp addresses

[recipients_smtp_cc] "Cc" email recipients' smtp addresses

[recipients_smtp_bcc] "Bcc" email recipients' smtp addresses

[subject] email subject

[year] delivery year (00-99)

[year4] delivery year (1970-2038)

[mon] delivery month (01-12)

[day] delivery day (01-31)

[hour] delivery hour (00-23)

[min] delivery minute (00-59)

[sec] delivery second (00-59)

[dayofweek] delivery day of week (1-7, 1-Sunday)

[syear] submit year (00-99)

[syear4] submit year (1970-2038)

[smon] submit month (01-12)

[sday] submit day (01-31)

[shour] submit hour (00-23)

[smin] submit minute (00-59)

[ssec] submit second (00-59)

[sdayofweek] submit day of week (1-7, 1-Sunday)

attachment variables

[att_name] attachment name

[att_short_name] attachment short name

[att_name_wo_ext] attachment name w/o extension

[att_ext] attachment extension

[aday] day (01-31)

[ahour] hour (00-23)

[amon] month (01-12)

[amin] minute (00-59)

[asec] second (00-59)

[adayofweek] day of week (1-7, 1-Sunday)

[ayear] year (00-99)

[ayear4] year (1970-2038)

return part of variable

[variable:start:length]

It is possible to return just the portion of variable specified by the start and length parameters.

start:

If start is non-negative, the returned string will start at the start'th position in string, counting from zero. For instance, in the string 'abcdef', the character at position 0 is 'a', the character at position 2 is 'c', and so forth.

If start is negative, the returned string will start at the start'th character from the end of string.

If string is less than or equal to start characters long, empty string will be returned

length:

If length is given and is positive, the string returned will contain at most length characters beginning from start (depending on the length of string).

If length is given and is negative, then that many characters will be omitted from the end of string (after the start position has been calculated when a start is negative). If start denotes the position of this truncation or beyond, empty string will be returned.

If length is given and is 0, the substring starting from start until the end of the string will be returned.

examples:

Assume that Subject is "abcdef" then

[subject:1] returns "bcdef"

[subject:-2] returns "ef"

[subject:-3:1] returns "d"

[subject:0:-1] returns "abcde"

[subject:2:-1] returns "cde"

[subject:4:-4] returns empty string

[subject:-3:-1] returns "de"


return to the top

Company

mailing address

ORNIC USA, LLC

4747 36th Street, Suite 137020

Long Island City, NY 11101

USA

webs

www.inboxrules-for-outlook.com

www.ornicusa.com

emails

general: info@ornicusa.com

sales: sales@ornicusa.com

support: support@ornicusa.com

purchase

To order InboxRULES launch your web-browser to the ORNIC USA, LLC store page at http://www.ornicusa.com/purchase.

return to the top